FSM Stage Validation
(0)
166
Brian McMaster

FSM Stage Validation

FREE
Technical name
fieldservice_stage_validation
License
AGPL-3
Secure dependencies
N/A
FSM Stage Validation

FSM Stage Validation

Beta License: AGPL-3 OCA/field-service Translate me on Weblate Try me on Runboat

As the stage of a field service document progresses, it may be important for specific fields of the document be completed.

For example, when a field service order enters the ‘Complete’ stage, the fields for ‘Actual End Date’ and/or ‘Resolution Notes’ should be set.

This module allows you to raise a Validation Error if the designated fields are not set when moving to a new stage. Since stages can be used for field service orders, workers, locations, or equipments, this logic is available to be applied to each document type.

Table of contents

Configuration

  • Go to Field Service > Configuration > Stages
  • Create or select a stage
  • Select one or more fields to be validated

Usage

  • Follow steps outlined in Configuration.
  • User will receive validation error if a field is not set when attempting to move to a new stage.

Known issues / Roadmap

The roadmap of the Field Service application is documented on Github.

Bug Tracker

Bugs are tracked on GitHub Issues. In case of trouble, please check there if your issue has already been reported. If you spotted it first, help us to smash it by providing a detailed and welcomed feedback.

Do not contact contributors directly about support or help with technical issues.

Credits

Authors

  • Brian McMaster

Contributors

Maintainers

This module is maintained by the OCA.

Odoo Community Association

OCA, or the Odoo Community Association, is a nonprofit organization whose mission is to support the collaborative development of Odoo features and promote its widespread use.

Current maintainers:

brian10048 max3903

This module is part of the OCA/field-service project on GitHub.

You are welcome to contribute. To learn how please visit https://odoo-community.org/page/Contribute.

0.0 / 5.0
based on 0 ratings
This theme does not use any external Python dependencies.

Available languages

Language % translated
Spanish / Español
100%
Spanish (AR) / Español (AR)
100%
Italian / Italiano
100%
French / Français
71%
Portuguese / Português
71%
Turkish / Türkçe
0%